御坂網路司令塔

偉大光榮正確的中土國民會萬歲

为七十五亿同胞求幸福,以尽公民之责任。

有一种相信自己的能力和愿望能突破这种枷锁 去过一辈子“青春”一样的生活
而不去回归上一代人的生活方式。
做女孩子是属于自己的未来中很关键的一部分
但是如果整个未来很绝望的不属于自己
或者换句话说 如果这个世界到时候逼迫我去回归一个“正常女性”的生活……
那何必呢
——神乐坂豆腐

这世界真可怕。这世界就是这么可怕。

还记得许多次和家人讨论的那个话题……如果这个世界都在走法西斯主义路线……还要不要抗争。
“有人选,凭什么不能当?”“希特勒也是人民选上来的。”“希特勒能让德国人民过上好日子,能让每个德国家庭开上甲壳虫,你能吗?”(非原话)

有时候御坂自己也会怀疑,御坂作那么多死,是为了什么。
难道是为了在讣告上写上“革命的一生战斗的一生”吗?
那和“文正”“忠武”有什么区别啊。
一个真正的唯物主义者怎么会信这种东西呢。

如果说有的人牺牲生命去完成某种事业……人死了真的能带走回忆吗?那一定是想要给这个世界留下些什么吧。

被剥削被压迫的阶级,如果不同时使整个社会一劳永逸地摆脱 任何 剥削、压迫以及阶级差别和阶级斗争,就不能使自己从进行剥削和统治的那个阶级的控制下解放出来。——马、恩《共产党宣言》

人的本质不是单个人所固有的抽象物,在其现实性上,它是一切社会关系的总和。——马克思《关于费尔巴哈的提纲》

从这个意义上讲,就算人类被某种继承了人类文明的人工智能之类的东西所替代……也不能算人类社会的灭亡吧。

我们必须明白,人类在宇宙漫长的时间过程里终究是个匆匆过客,指不准什么时候就被各路大大给作死了。这是最好的时代,也是最坏的时代——资本主义社会发达的物质文明,真的能在社会主义社会中延续下去吗?我们是否真的必须面对三百年以上的自然灾害?——但是有一点是可以肯定的,资本主义社会终究有它的尽头,接替它的也许并不是社会主义,而可能是野蛮状态。

这么说还是有些宿命论了。也许自我奋斗在历史的行程面前就像是螳臂当车,可是螺旋上升着的历史究竟是站在谁的一边呢?

善良与凶恶相对的时候,前者显得是多么稚弱而后者显得是多么强大呀。……然而人们还是喜欢善良、欢迎善良、向往善良。——王蒙《善良》

我永远站在鸡蛋这一边。——村上春树

如今,资本主义民族国家的掌权者再一次发动法西斯蒂的潮流,那钢铁洪流更是对人民诉说着自己的骄傲。
哦,不过是当权派续命的手段而已。
“为了强大的祖国”,各路牛鬼蛇神都被搬出来了:乡贤、国学、女德、自信、文化、传统、宗教、邪教……每一个词汇都象征着旧时代想要给人民传达的恐惧。

可是人民很快就将不再恐惧了。只要我们努力。

御坂大概是希望,并且愿意尽自己的一切努力,去活成一盏明灯——就算有一天熄灭了,也至少照亮过这个世界。

敵なんぞ、怖がらず。学べば、戦う!——周郁辉《中国少年先锋队队歌》

中国将废除国家主席连任限制

出处:《晨星》,即原大不列颠共产党党报《工人日报》

中共中央委员会预计于本周举行投票,废除现时禁止“连续超过两届”担任国家主席或或国家副主席的规定。

中央委员会自明天起举行为期三天的会议,研究政治局常委会提出的删除该条款的建议。这将会允许现任主席习近平将任期延长至2023年之后。

中央委员会也有可能支持政治局“将‘习近平新时代中国特色社会主义思想’纳入宪法”的提案。这一思想将被添加到现有的马克思列宁主义、毛泽东思想、邓小平理论、三个代表重要思想和科学发展观之后。

新华社表示,中央将召开会议,讨论党和国家机构体制改革方案、国家经济和社会发展情况,并提出国家和和全国政协领导职位候选人。

根据新华社的声明,政治局认为党和国家机关的现存结构不足以满足“新时代”多项任务的需求。

新华社说,党要下定决心解决体制性障碍,充分发挥中国社会主义制度的优势。

党的领导层表示,中国将继续采取积极的财政政策和稳健的货币政策,以实现2018年的经济和社会发展目标。

那么,我就想问一句:习先生连任好不好啊?

China-DRM PDF 文件破解

御坂的高中同学 Schwoel Lue 今天来找御坂,说有一套题库是 exe 封装过的 pdf,只能看,无法复制出来。他发来了自动生成的机器码和供应商以此发出的密码,但在御坂的电脑上机器码不同,仍然无法打开。

御坂先是用 Process Explorer 导出了一个 dump,再用 /bin/strings 命令查看,发现其中有 china-drm.ini 字样。故上网搜索破解方法。

找到教程之后,御坂照着用 OllyDbg 打开,却根本找不到字符串 -00000000
后来怀疑到可能是加壳了,但御坂怎么可能会脱壳啊!

御坂就在硬盘里找文件,当然是一无所获——但却发现了一个只有两个 ini 的 C:\china-drm 文件夹。回想第一次运行弹出的对话框,御坂决定删除这个文件夹试试。
删掉这个文件夹,安装 Adobe Reader 的对话框会再次弹出,此时在 OllyDbg 中点暂停,再按照上述教程的步骤操作,即可修改机器码。

改掉机器码之后输入密码,文件可以在程序中打开,却不能复制。这时可以用 Shadow Copy 将看着差不多的临时文件 C:/Users/username/AppData/Local/Temp/随机字符串.tmp 复制出来,修改扩展名为 pdf 就可以了。事实上,在他的电脑上,就算不执行上述的操作,直接用 Shadow Copy 也可以导出 PDF……

14天从 DCNA 到 CCNA:备考笔记(不完全最终版)

回想自从参加 DCNA 考试以来的这些日子,我需要的,其实恰恰是:
照镜子,正衣冠,洗洗澡,治治病。——题记

(学习尚未成功,错误随时更改)

单词

  • hub and spoke 轴辐路网
  • congestion 吞吐量
  • converge 收敛

CDP协议

  • 私有,工作在链路层
  • 默认开启

    1
    2
    3
    4
    5
    6
    show cdp neighbors detail
    show cdp neighbors
    conf t
    no cdp run
    int yottabitethernet 0/0/0
    cdp enable
  • LLDP 标准,同样在链路层!(lldp run……)

Telnet

  • 先配 IP
  • 必须配置密码

    1
    2
    3
    line vty 0 4
    password <password>stp
    login
  • 连到本机:

    • show users !! 第一列数字为线路编号
    • 踢人 (config)# clear line 线路编号
  • 连到别的机器:# telnet <ip>

    • 切换回主机:C-S-6 x
    • 恢复连接:# show sessions
      • 回车恢复最近
      • 其他需输入编号
    • 退出登录/断开连接:# disconnect 连接编号

      ping
      ping ipv6

系统启动

(config)# boot system <?>
选择特定 IOS 版本,默认最新
系统备份
(先搭 TFTP 服务器)
(config)# dir flash:
(config)# copy flash: tftp:
恢复
(config)# copy tftp: flash:

NTP

  • 时间提供者(红色连衣裙)ntp master
  • 客户端要使用 ntp server <ip> 指定 NTP 服务器地址

交换

  • 类型标明三层协议
  • MDI/MDIX 之间用交叉线,MDI 之间或 MDIX 之间用直通线。自动翻转 auto-mdix 就不必管了(
  • aggregated chassis 说白了就是神码交换机的堆叠(迫真DCS3950)能减少管理负担(management overhead)

    生成树

  • STP 定义在 802.1D 中,端口状态 Blocking Listening Learning Forwarding Disabled
  • RSTP 802.1w 的 switch port 只有 Discarding、Learning 和 Forwarding 三种状态
  • Rapid PVST{,+} 思科自己的,基于 RSTP,支持 VLAN

    VLAN

  • 管理 IP 放在非默认 VLAN
  • 连接 IP 电话的端口要设置为 switchport mode access,用法 switchport voice vlan <VOICE-VLAN>

    DTP

  • 802.1Q 或 ISL
  • Cisco proprietary
  • 协商 Trunk 用的
    access / trunk 强制,但通过 DTP 告诉对方自己的类型
    dynamic auto 默认选项,端口为 Access 除非对方是 Trunk
    dynamic desirable 端口为 Trunk 除非对方是 Access

(config-if)# switchport nonegotiate 直接禁用 DTP,对方就算开了 dynamic 也知不道是 access 还是 trunk

单臂路由

ROAS:Router-on-a-stick
主接口不 encapsulation,但要 no shut
子接口(g0/0.10、f1/1.20……) encapsulation dot1q <vlan id> 并配置网关地址。

三层交换

在三层交换机上实现路由功能,除了通过 SVI 接口(int vlan )以外,还可以将端口设置为三层接口,并直接配置 IP:(config-if)# no switchport
三层 EtherChannel 也要 no switchport(待测),地址配在 int port-channel 1

EtherChannel

说白了就是端口汇聚

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
int range f0/1-2
channel-group 1 mode ?
active Enable LACP unconditionally !! 主动 LACP
auto Enable PAgP only if a PAgP device is detected !! 被动 PAgP
desirable Enable PAgP unconditionally !! 主动 PAgP
on Enable Etherchannel only !! 强制启动(无法热备)
passive Enable LACP only if a LACP device is detected !! 被动 LACP
int port-channel 1
ip addr <ip> <netmask>
do show etherchannel 1 summary
Flags:
D - down | P - bundled in port-channel
I - stand-alone | s - suspended
H - Hot-standby (LACP only)
R - Layer3 | S - Layer2
U - in use | f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
……
……

路由

OSPF

  • 标识符用 RouterID
    1. 手工设置
    2. 最大的 loopback 接口地址
    3. 最大的物理接口地址
    4. 报错

EIGRP

  • 标识符同 OSPF……?
  • 几种距离
    • Feasible Distance (FD):某路由器RtA到目的网段的距离
    • Reported Distance (RD)(部分教材称AD):某路由器RtA的邻居(向RtA通告的)到目的网段的距离
    • Successor: 到目的网段 metric 最小的路径
      • Successor 的 metric 值成为RtA到目的网段的FD
    • Feasible Successors: Successor 掉线后的替代者
      • metric 比 FD 大,不然就是 Successor 了
      • RD 比 FD 小,否则不会成为 FS。设路径为:
        1. RtA -> RtB == 20, RtB -> RtC == 20
        2. RtA -> RtD == 20, RtD -> RtB == 30, RtB -> RtC == 20
        • 2 不会成为 FS,因为 RtD 向 RtA 通告的 RD == 30+20 == 50 > FD == 20+20 == 40
        1. RtA -> RtB == 30, RtB -> RtC == 20
        2. RtA -> RtD == 20, RtD -> RtB == 20, RtB -> RtC == 20
        • 1 为 Successor, FD==30+20==50 > 20*3==60
        • 2 为 FS,RD==20+20==40 < FD ==50
  • Hello 包
    • 一个 5 秒
    • 15 秒没发,直接 Goodbye Message(由邻居发)

eBGP

  • IGPs
    • 目的
      1. 学习路由
      2. 选择最佳路由
      3. 收敛
  • BGP
    • 目的
      1. 学习路由(通告一个前缀的可达性)
    • path attributes (类似 metric)每条 PA 是一种关于某条目优劣的度量。
    • best path selection 从两条路径中选一条更好的。
    • Single Homed: 联通单线
    • Dual Homed: 联通复线
    • Single Multihomed: 联通电信双线
    • Dual Multihomed: 联通电信双复线(怎么一股铁道游击队的气息)
      1
      2
      3
      4
      5
      6
      7
      8
      9
      10
      11
      12
      13
      14
      15
      16
      17
      RtBroncoBorder# show ip bgp summary
      BGP router identifier 192.168.1.1, local AS number <隐藏真实AS号>
      BGP table version is 3, main routing table version 6
      2 network entries using 264 bytes of memory
      2 path entries using 104 bytes of memory
      1/1 BGP path/bestpath attribute entries using 184 bytes of memory
      2 BGP AS-PATH entries using 48 bytes of memory
      0 BGP route-map cache entries using 0 bytes of memory
      0 BGP filter-list cache entries using 0 bytes of memory
      Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
      BGP using 632 total bytes of memory
      BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs
      Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
      192.168.0.2 4 52 26 25 3 0 0 00:23:46 4
      RtBroncoBorder#

好吧其实我大 PT 根本没法全都用真实 AS 号,毕竟32位不支持(
至于哪个机构能搞到 AS52,这个御坂不用说了吧……

HSRP / VRRP / GLBP

不是路由协议,而是热备协议!!!!!!!!!!

HSRP

  1. 第一版 224.0.0.2(全部路由器)udp 1985 虚 MAC 00:00:0c:07:ac:XX
  2. 第二版
    • IPv4 224.0.0.102(只有 HSRP)udp 1985 虚 MAC 00:00:0c:9f:fX:XX 与第一版不兼容
    • IPv6 ff02::66 udp 2029 00:05:73:a0:0X:XX
  3. Master == Active
  4. 没 priority 用 IP 地址

R1 R2 同时以 g0/0 接入 S1
先配置 R1:

1
2
3
4
5
interface GigabitEthernet0/0
ip address 192.168.2.11 255.255.255.0
standby version 2
standby 0 ip 192.168.2.1
standby 0 priority 110 !!! 默认为 100

此时 R1 上 show standby brief,R1 Active, Standby unknown
S1 若配置了 int vlan 1 中的管理地址,应该是可以访问网关虚地址 192.168.2.1 的,show arp 对应的 MAC 地址也是按规则虚拟的

再配置 R2:

1
2
3
4
5
interface GigabitEthernet0/0
ip address 192.168.2.12 255.255.255.0
standby version 2
standby 0 ip 192.168.2.1
standby 0 priority 233 !!! 与路由表 metric 相反,数字越大越优先

S1 结果不变
然而此时 R1, R2 上 show standby brief,结果均为 R1 Active, R2 Standby。HSRP 讲究先来后到,后加入的网关无法覆盖之前的网关,哪怕优先级高过所有之前的网关,也会是 Standby。

之后在 R2 的 g0/0 上 standby 0 preempt,则 R2 Active,R1 Standby(R2优先级高)
如果 R2 断线,则再次回到 R1 Active, Standby unknown 的状态。

(如果两边都是 Preempt,仍按优先级办理)

功能 Version 1 Version 2
IPv6 没听说过 吼啊
Hello timer的最小单位 +1s +1ms
群组数量 0~255 0~4095
MAC地址 0000.0C07.AC?? 0000.0C9F.F???
IPv4组播地址 224.0.0.2 224.0.0.102
每个路由器是否有单独ID 没有任何的这个意思 当然啦

服务与安全

日志

syslog

Level Keyword Level Description Syslog Definition
emergencies 0 System unstable LOG_EMERG
alerts 1 Immediate action needed LOG_ALERT
critical 2 Critical conditions LOG_CRIT
errors 3 Error conditions LOG_ERR
warnings 4 Warning conditions LOG_WARNING
notifications 5 Normal but significant condition LOG_NOTICE
informational 6 Informational messages only LOG_INFO
debugging 7 Debugging messages LOG_DEBUG

默认只有 7 debugging 不显示

ACL

  • 一旦某条目匹配成功,就不再向下匹配其他条目

  • Standard numbered ACLs (1–99)

  • Extended numbered ACLs (100–199)
  • Additional ACL numbers (1300–1999 standard, 2000–2699 extended)
  • Named ACLs
  • Improved editing with sequence numbers (排序)

    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    (config-std-nacl)# no 20
    # show ip access-lists 24
    Standard IP access list 24
    10 permit 10.1.1.0, wildcard bits 0.0.0.255
    30 permit 10.1.3.0, wildcard bits 0.0.0.255
    (config-std-nacl)# 5 deny 10.1.1.1
    # show ip access-lists 24
    Standard IP access list 24
    5 deny 10.1.1.1
    10 permit 10.1.1.0, wildcard bits 0.0.0.255
    30 permit 10.1.3.0, wildcard bits 0.0.0.255
  • IPv6 只有命名扩展 ACL,接口上应用是 ipv6 traffic-filter <ACL 名称> <in|out>

QoS

流量的属性:

  • Bandwidth 带宽
  • Delay 延迟
    • One-way Delay 单向延迟
    • Round-trip Delay 往返延迟
  • Jitter 抖动
    • 延迟的变化量
    • 第一个包延迟 300ms 第二个也是 300ms,抖动为0
    • 第一个包延迟 300ms 第二个 310ms,抖动为 10ms
  • Loss 丢包
    • 不一定是网线不好或者广域网服务不好,也可能是设备队列满了

分类标记

  • CoS/PCP
    • 802.1Q 首部的第三个字节的前三位
  • trust boundary
    • 边界以外为终端用户,不许设置 QoS 标记(否则岂不是随便伪造)
    • 边界一般在接入交换机,但遇到 IP 电话则是在电话上(电话自带交换机)
Field Name Header(s) Length (bits) Where Used
DSCP IPv4, IPv6 6 End-to-end packet
IPP IPv4, IPv6 3 End-to-end packet
CoS 802.1Q 3 Over VLAN trunk
TID 802.11 3 Over Wi-Fi
EXP MPLS Label 3 Over MPLS WAN

PPP

Router(config)# hostname R1
R1(config)# username R2 password samepassword
R1(config)# int s1/0
R1(config-if)# encapsulation ppp
R1(config-if)# ppp authentication chap
R1(config-if)# ip addr 192.168.0.0 255.255.255.252
R1(config-if)# no shut

R2(config)# hostname R3
R3(config)# int s1/0
R3(config-if)# encapsulation ppp
R3(config-if)# ppp authentication chap
R3(config-if)# ppp chap hostname R2
R3(config-if)# ppp chap password 0 samepassword
R3(config-if)# ip addr 192.168.0.0 255.255.255.252
R3(config-if)# no shut

用户名为本地主机名
密码双方相同
配置验证数据库采用对端主机名+密码

后记

本御坂已经于2018年1月10日参加 CCNA R&S 200-125 考试并通过。
后续证书注册过程仍在进行中。

感谢母校培养了御坂的网络技能。
感谢职业高中学生自治联合会hitorino 社区LinuxHub 社区对御坂的鼓励。
最重要的,感谢麦金塔用户麦金塔棕色胶布雨衣的大力支持,没有她的话,御坂不会去报考的。

双绞同轴光纤 路由协议收敛
六类网线B序 测线仪器不闪
对面成功彼岸 有谁能ping得见
只有奋发图强 刻苦去钻研
图层磁性套索 时轴形状补间
公式填充背景 把二叉树寻遍
知识从不欺骗 文明历史经验
谨将这句箴言 铭记在心间

中土国民会列传:奇袭白虎团

本文純屬虛構。

第一摺

(圖靈一百〇六年十一月某日
(岑特蘭共和國洛都附近的穆多里「CMYK 幼稚園」門口
(一列防暴警察嚴陣以待

(抗議羣衆上)
美秦(居中,轉身,唸到)花有重开日,人无再少年;不須悶聲謀富貴,只求一家竟平安。夫婦中產喜得女,勞苦工作不得閒。爺姥下崗去世無人顧,託了關係保住女兒戶口,重金寄送幼稚園。誰知世上竟有如此獸,藐視紅日黨青天。假扮郎中施毒藥,行賄就把我女姦。問那禽獸是何人?卻統治「保家衛國屢立戰功」白虎團!強壓政府偷監控,以死相逼家長二百人!卻不知,百姓獨輪軍糧送爾上皇座,今日照作法西斯蒂把你趕去斷頭臺!團結的人民永遠不被擊潰!
衆抗議羣衆 團結的人民永遠不被擊潰!團結的人民永遠不被擊潰!團結的人民永遠不被擊潰!團結的人民永遠不被擊潰!

美秦(清唱)起來/歌唱/我們就要勝利/憤怒的聲音/將帶領我前進/我要請你/與我並肩同行/你會看見/我們的歌如茉莉花一樣/綻放/在紅色的曙光/鮮血覆蓋/在自由土地上。
美雲(唱)起來/對抗/我們一定要勝利/自己的權益/要自己去努力/不要/忘記/絕對不要放棄/生存的戰場裡/讓勞動和抗爭覆蓋這片/土地/讓自由的聲音/召喚我們/無懼的向前行
(齊唱)而如今/這人民/從挫敗/中站起/用劇烈/的聲音/在呼喊/前進!
(齊喊)團結的人民永遠不被擊潰!

(遠處傳來槍聲)
閻團長(單手持駁殼槍,從遠處走來)都給我閉嘴!你們TM的是想造反麼!

第二摺

閻團長(昂首挺胸上,云)老子閻望葉,白虎團上校團長是也。海東打狗人氏,「河洛郡王」閻鋁山曾孫也,可惜家道中落,當個小破團長還要花個幾萬銀子;自己兄弟玩牠幾個小鬼,居然還要本團長親自出馬擺平。

(李所長出列,向閻團長敬禮)
閻團長(慵懶地回了一個舉手禮,說道)這的防暴我們接管了,你們沒啥別的事就撤吧。
李所長 上校同志,根據《岑特蘭共和國戒嚴法》,軍事管制需要行政院決定,由閣揆發佈……
閻團長(不耐煩)放NM的P!老子有槍有錢上面還有人,你們快滾,別耽誤俺們執行任務!
(警察們讓路。士兵們上,持槍對準抗議羣衆)
閻團長(一把揪住神樂坂美秦的領子)剛才是你喊的口號吧?小子口氣不小啊?
抗議羣衆(齊聲)是我們一起喊的!
閻團長 喲,你的同夥還挺護着你的。是無聯的人叫你們來的吧!受了無匪的煽動不要緊,現在向我道歉,然後發誓退出一切和無聯的關係,我可以立即放你們走。
美秦(怒目而視)是又怎樣?(突然一個哆嗦冷靜下來)我就是洛都無線電管理委員會的科長,可我今天是作爲一個爸爸來質問你的。(又激動)你們就仗着手裏有點兵權,作出如此獸行,連政府官員的子女都不放過,就不怕哪天風紀會把你們千刀萬剮?
閻團長 你知道我在說什麼!知不知道現在就在清查政府裏潛伏的無政府主義者?(掏出駁殼槍)我現在就能把你軍法從事!

李所長(在旁邊)上校同志,軍事法院只受理現役軍人、軍隊在編職工的以及司法院授權的刑事案件……
閻團長 快滾!再廢話把你也軍法從事!
李所長(嘟囔着下)這世道還有沒有黨法了……

抗議羣衆(激動而憤怒地)打倒僞國家黨!
閻團長(把神樂坂美秦踩在腳下,用槍指着抗議羣衆)小兔崽子再說一句試試?你們一個都活不了
神樂坂美秦(聲音嘶啞地)打倒僞國家黨!還我岑特蘭!
閻團長(收起槍,掏出匕首,在美秦喉管劃過)這樣死掉最「慶正」了吧?絕對是符合孔教教規的食物!要不要我再唸兩段《樂經》?哈哈哈哈……

僞通信兵A(慌忙跑上)團座,不好了!
閻團長(扭頭)咋了?你慢點說!
僞通信兵A 一營全營把全團的卡車都開走了!
閻團長(震驚)啊?什麼鬼?
僞通信兵A 去的是井口方向,輔導長說是那邊一片荒涼,怕是投奔無匪去了!
閻團長(憤怒)MD,兄弟們撤!跟我殺叛徒去!
士兵們(齊聲)是!(士兵下)
抗議羣衆(呼喊)法西斯遭報應了!
閻團長(再次掏出駁殼槍)給我閉嘴!(衝着前排羣衆腿部一通掃射)
(羣衆A,B,C倒地)
羣衆D 快送醫!

第三摺

(岑特蘭共和國洛都西郊市井口町一處廢棄的軍事基地
上官石(緩步上,詩云)昔日入伍井口鎮,爲護一方有平安。屢立戰功猛獸旅,保家衛國白虎團。今朝起義先賢地,爲求祖國換新天。長官無道未自死,繼續革命待來人。欲張宏德必經大兇險,自古叛軍活命百中三。我絕對不知道,我作爲一個國民軍的營長,怎麼就到井口來了呢?所以美京同志跟我講話,說「中央都決定啦,你來當總司令」,所以後來我就唸了兩句詩,叫「敢同國家爭生死,豈因禍福讓寸分」,那麼所以我就來到井口町。啊,我可不是來跳井的,不然豈不是成了「蛤絲跳井——不董裝董」了麼?(回頭)蔣副官,估摸着他閻王爺該來了,做好防禦準備了麼?
蔣民(跟上前,說)回營座,都準備好了。汪參謀規劃了兩條會師路線。二連、三連分別管大門和後門,一連負責月臺,通信班已經在修地下鐵的信號系統了。

(背景音,有劣質喇叭聲)報告營座,團座把二營和團部警衛排都帶了來,已經都搭好掩體了!現在在對峙中,他們說非要您去才談判!
上官石(繫上紅領巾)我馬上就來。
(衆人拔槍,下)

上官石(進入工事,云)啊,團座您也來了,有失遠迎,請團座當面恕罪。
閻團長(假裝冷靜)你爲什麼把部隊拉到這裏?電話爲什麼不通?上官石,你這什麼鬼?
苟團副(小聲提醒)那個,團座,咱們團的確有收到命令,要整修井口軍事基地……
閻團長(不耐煩)那也得整團一起行動,而且是軍事基地,不是部隊大院!他這明明就是……
上官石 團座,您聽我說一句。
閻團長 你說啊!
上官石 團座,我是您的老部下,圖靈七十九年時我就跟着您東征西戰。我雖然姓「上官」,但從不想着當官,圖的是國家的自由與解放。平時我積極向組織靠攏,您作爲我的入黨介紹人不會看不見吧?
閻團長 上官石,我沒時間聽你瞎丁丁切蛋!有話快說,有什麼快放我不必說了吧?
上官石 團座,那我就說了。這次三營長的事,我實在是忍不了。每次向憲兵隊舉報,都被您和輔導長擋了回來;向地方的風紀會舉報,竟然也被無視。
閻團長 MD我就知道是你小子捅出去的,家醜不能外揚,識得唔識得啊?
上官石 那難道我們國家的軍隊,就這麼醜着嗎!我上官氏打算改弦易轍,接受共和軍的改編。我和蔣營副主意已定,望團座不要強人所難。我們從未對團座有過意見,就是看不慣三營長這種敗類穆無黨法,胡作非爲!
閻團長 上官石,你想造反不成?晉軍三五八團的錢伯鈞,那比你們不知道高到哪裏去了,我外公把他一槍爆頭!上官石、蔣民,你們想要這叛徒的下場嗎?
蔣民 沒有任何的這個意思……團座,剛才您問我啊,我可以回答一句「無可奉告」,您又不高興,那怎麼辦?我覺得您還是要學習一個。我也給您着急啊,真的。團座你們有一個好,全岑特蘭跑到什麼地方,比禁衛軍跑得還快。但是呢,講起這新時代岑國特色自由主義的那一套理論,就 too simple, sometimes naïve.
閻團長 接着說,我看你怎麼裝。
蔣民 我認為部隊經商是一個腐蝕劑。因為歷史經驗已經告訴我們,任何一個國家如果軍隊經商以後,沒有一個不腐敗的,最後必然是渙散了軍心,讓有良知的軍人離開。先主席 江公曾經說過,軍隊一律不得經商。可是呢?這師部那邊搞權錢交易,公然賣官也就算了,三營居然拿幼稚園做妓院,已經是別說黑社會,就連東阿國的侵略者都做不出來的吧!地獄的下面是他們的地獄,團座想給他們陪葬我也攔不住!
上官石(唱)霸王開坦克,烏雀坐飛機。禽獸混進了猛獸旅,惡虎潛伏在白虎團。法西斯盤踞國家黨,政府救不了岑特蘭。先烈捍衛了我大岑,可如今是要完!
閻團長(唱)反了你們無聯匪,大岑何時姓上官?
上官石 那就別怪是你大岑、你大國家黨逼我們了!二連!
(電動大門徐徐關上)
(槍聲)

第四摺

(井口大院地下一層)
三連長(拿起電話)七排,你們那邊怎麼樣了?
(旁白,電話)還好,就是子彈快沒有了!
三連長 子彈都沒了,怎麼個好法?手榴彈還有嗎?
(旁白,電話)用了一半了!
三連長 不是叫你們省着點嗎!集中手榴彈,趕緊撤!(掛掉電話)

三連長(拿起電話)八排,你們那邊怎麼樣了?
(旁白,電話)快頂不住了!
(嘭)

三連長(拿起電話)九排!
(旁白,電話佔線)

三連長 通信兵!叫九排派一個班,掩護營座撤退!
警衛員 通信兵剛出門就犧牲了!
三連長 可惡,我一定會回來的!撤!

(井口大院地下六層,洛都地下鐵1線西苑驛月臺)
上官石(上,用柺杖敲地,唱道)敵衆我寡無後援,此戰未捷意料間。莫道石人一隻眼,挑動大河天下反。全國抗暴已大勢,資本將近鬼門關。今夕爾等平「暴亂」,別忘星火可燎原。
上官石(登上列車,道)蔣副官,無政府主義聯盟那邊,接應的人都聯繫上了麼?
蔣民 聯繫好了,沿着這條線只能開三站地,然後就得在五權山站下車。他們在那裏接應我們。
上官石 蔣民,你會開火車麼。
蔣民 營座,我可是東南運輸大學畢業後參軍的。這幾站都是廢棄的軍管站,不會有哨兵查的。

(嘭)
蔣民 再不走來不及了,您下令吧。
上官石 開車!先開慢一點,等到咱們的兵都上車以後,立即加速。
蔣民 是!

(旁白,廣播)歡迎乘坐洛都地下鐵軍管101線列車,本次列車是由西苑站開往黑風洞站方向。列車運行前方是一石站……

第五摺

美京(撥開樹枝,上,作偵查狀,打手勢呼衆游擊隊上)
江一山 美京,你不是說白虎團有個加強營要過來參加起義麼?爲何某還是未來?
美京 一山同志,三個小時以前他們發了消息過來,說遭遇圍剿,剛剛突圍。
美京(瞭望,云)看!他們來了!

(未完待續)

在 STM32F103C8T6 最小系統板上執行 FSIJ gnuk

御坂御坂好久沒寫技術 blog 地說道:


STM32F103C8T6 的最小系統板,64KiB FlashROM,從淘寶買的。
SWD 下載線,ST-LINK V2,同上。
arm-none-eabi 的工具鏈。

下載 gnuk 的代碼:

1
2
3
4
git clone git://git.gniibe.org/gnuk/gnuk.git/
cd gnuk
git submodule init
git submodule update

target 選同是 64KiB 的 STM8S_DISCOVERY,然而這個芯片在 gnuk 1.1.4 就不再受到支持(內存太小,而 gnuk.elf 的尺寸變大了——估計是因爲 RSA 4096,所以裝不下),所以必須
git checkout release/1.1.3
切換到 1.1.3 版本 tag。

然後這個版本是不能編譯的:
https://gist.github.com/misaka4e21/79a41555ed74a31df169d569f8be5bd2
把 inline 函數改掉就好了。

然後到 src 裏 ./configure --target=STM8S_DISCOVERY --vidpid=<????>:<????>make 就可以了。

最後燒寫用的到底是 tool/stlinkv2.py 還是 tool/openocd-script/write.tcl,御坂自己也記不清了,抱歉。

一點 AOSCC 2017 記錄

第一天

合影.jpg
這回吸取教訓,第一天就合影。

Alternative-合影.jpg
合影的另一個版本。

第二天

ThinkPad-合影.jpg
ThinkPad User Group 的合影。

ThinkVision.jpg
連顯示器都是 Think 品牌的!(畢竟教育口統一採購:聯想、清華同方……)

Alternative-ThinkPad-合影.jpg
從窗外拍的 ThinkPad User Group,效果不太好。

第三天

嗯。下面沒有了。

嘟、御坂御坂請各位前往 徽女裝少女盟附設開源社區同志 查看更多照騙道。

第三次告雨衣書

謝謝妳,我放下了。

嘟、御坂御坂一邊起草 《第三次告雨衣書》 一邊說道。

中土國民會中央風紀委員會第三次告雨衣書

敬啟者

是時候正視現實了。

此人明白,她(如果允許御坂使用這個代詞的話)並不是一個必要、需求和/或值得被(以那種方式)愛的人。

此人確認,在此之前,他/她/牠/它喜歡過其他人(其中包括被知道的和不被知道的、還記得的和已經忘記的)。就像雨衣也有自己喜歡的人一樣。

不止一個。

此人並且確認,在此之後,她也喜歡過其他人(其中包括雨衣認識的、非常認識的和不太認識的)

要命的是,同時有好幾個……

此人知道,就此而言,此人既不是一個好戀人,也不是一個好朋友。既不是一個好孩子,也不是一個好學生。她這輩子做了太多不該做的事情,卻依然沒有認清錯誤。

雨衣不要覺得內疚。非要說對不起的話,是御坂對不起妳。

如果雨衣願意原諒御坂的話。

如果說御坂就這樣不喜歡雨衣了,那當然是假的。但御坂的確不是「那種」喜歡了。謝謝妳,御坂終於做到了。

御坂本來想請求,和雨衣做普通朋友,再見到也不會尷尬的那種。不過經歷了最近一些不可控事件,御坂相信自己是沒有這個資格了。

那麼,有緣再會吧。只要雨衣願意,本御坂,這次沒有網路——Misaka is enough——仍然願意盡力做雨衣(不敢稱最)堅強的後盾。

真心祝妳幸福。

此致
雨衣前輩

御坂0x4e21
阿蘭圖靈一百〇六年,國際不再恐懼同性戀、雙性戀和跨性別者日

致雨衣書

御坂註冊這個域名還沒發過 genderqueer 相關的東西,今天發一篇習作吧。
御坂御坂感覺英語期末要掛道。

You wore a Mackintosh. Yes, I see.

It is your armour. An armour, heavy and solid enough, can keep you safe yet also overwhelm you.
Yes, the world is too dangerous to let people expose their authentic emotion to, thus everyone does need to protect herself throughout all her life. As a proud member of LGBTQQIAA, you may be laughed when you behave, be depressed when you act, be condemned, if not persecuted, when you bravely come out of the closet. Even other LGBTQQIAAs might also criticize you in a very unfair way. It is never tolerated by human society who does not follow the standards and the guidelines.
Then you started closing your heart. You deny your feeling, you fake yourself - not the physical human being but you, the person decided by what you want, what you think and what you love. If I were writing a passage of chicken soup for the soul, I would make a criticism of the above in order to show my “healthy mentality”. I just won’t make a piece of big news. Instead, I will treat the denying and the mask as a tool used to defend your unique and unchangeable life. Who can defy the whole nation of cisgender and heterosexual tradition? Criticism is powerless in front of the social incapability.
Justifiable defense with a mental armour isn’t and will never be a crime.

However, hiding in the closet cannot be a permanent escapement, not to say a solution.
A person without acceptance of emotion is a zombie with perception of pain. I don’t know whether gender identity and sexual orientation are immutable, but I deeply understand that they are undeniable. You can hide yourself in a period of time, but you cannot live a free life with the mask of sensory deprivation.
In your whole life, you have to listen to, you have to face with, you have to accept yourself after all; in a larger sense, we cannot survive, we cannot forget, we cannot stand alone in a world fulfilled with terror and discrimination.
We are really lucky living in a community without death penalty due to sex identity, but it is still an imperfect world lacking in respect for differences.
Increasing popularity of non-straight jokes played by heterosexuals does not mean real LGBTQQIAA-friendly, since these are not based on friendliness but oddity. To promote the civilization progress, we have to stand out and make the change. We needn’t die a martyr; in contrast, we do need to live a proud and unyielding life. Without self-awareness, no one would like to care about you; without self-esteem, no one will respect you. We won’t be angry, since they want to prove that we are mad. Their behaviour will tell the truth that who are more ignorant than madmen.

The best defense is a good offense. In the face of hatred, love is more powerful than any armour or firewall. More than morality we need consciences, more than excitement we need critical-thinking, more than allegiance to the system we need devotion to our love. Regardless of sexual orientation and gender identity, may love trump hate.

And, Misaka Misaka writes sincerely.